Get in touch
Back
Maintenance

VIP service - Scheduled Upgrade Announcement 💪

Completed 20 Sep at 02:00am BST.

Cinevisa VIP Server
Completed

Maintenance completed

Posted 20 Sep at 02:00am BST.
Started

Hello Fellas ✌

Due to our commitment to deliver the best service possible, we are doing a major upgrade on the system.

(VIP service only will be impacted during the maintenance)

We are planning for this major upgrade on 19-September-2022 between (11 pm - 2 am UTC).(23h to 2h GMT)

You may experience interruptions for maximum 2/3H

Thank you for your continuous support and understanding.

The VIP Service will be back automatically for you once we finish, no need to create any ticket.


We’re gearing up for and building Cinevisa TV to be better than ever in 2022 and beyond!

Kind regards,

Posted 19 Sep at 11:00pm BST.