Get in touch
Back
Maintenance

Scheduled Maintenance

Completed 7 May at 01:00pm BST.

Cinevisa VIP Server
Completed

Maintenance completed

Posted 7 May at 01:00pm BST.
Started

Hello Fellas ✌

Due to our commitment to deliver the best service possible, we are doing a major maintenance on the system to prepare for today's big UFC event and some other major sports games.

(VIP service only will be impacted during the maintenance)

Planned Maintenance 07-May between (10 am - 1 pm UTC).(10h to 13h GMT)
this is the only timeframe we found with no special events broadcasted.

You may experience interruptions for maximum 2-3H (offline-Online status)

Thank you for your continuous support and understanding.

The VIP Service will be back automatically for you once we finish, no need to create any ticket.

Posted 7 May at 10:45am BST.