Get in touch
Back
Resolved

VIP Service

Started 2 Jun at 03:45pm BST.

Cinevisa VIP Server
Created

VIP Service is under quick maintenance for 15-30minute before weekend events. (No need to change anything on your app settings). Service will be back automatically once tho optimisations are done on server database from our side.

Posted 2 Jun at 03:45pm BST.